Prerequisites

Overview

To develop an application with the Mobile SDK, please read through and prepare the following items based on your platform of choice.

General

  • Knowledge and experience in iOS or Android development.

  • At least one compatible Apple or Android device.

  • A Yuneec drone that supports the Mobile SDK (highly recommended).  See list of compatible drones here.

iOS

  • Xcode 8.0 or higher

  • Deployment target of iOS 10.1 or higher

  • iOS Developer account

  • iPhone 6 or later             

Android

  • Android Studio 1.5 or higher

  • Device running Android Version 5.1 - Lollipop (API Level 22) or higher